
Chapter 13

Working With Drawing
Views-II

After completing this chapter you will be able to:
• Generate Annotations in the Drawing Views.
• Create Reference Dimensions.
• Add Notes to the Drawing Views.
• Add Surface Finish Symbols to the Drawing Views.
• Add Datum Feature Symbols to the Drawing Views.
• Add Geometric Tolerance to the Drawing Views.
• Add Datum Target Symbols to the Drawing Views.
• Add Center Marks and Center Lines to the Drawing Views.
• Add Hole Callouts to the Drawing Views.
• Add Cosmetic Threads to the Drawing Views.
• Add Weld Symbols to the Drawing Views.
• Add Multi-jog Leader to the Drawing Views.
• Add Dowel Pin Symbol to the Drawing Views.
• Edit the Annotations.
• Add BOM and Balloons to the Assembly.
• Add New Sheets in the Drawing Document.
• Edit Sheet Format.
• Create User-Defined Sheet Format.

Learning Objectives
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ADDING ANNOTATIONS TO THE DRAWING VIEWS
After generating the drawing views, you need to generate the dimensions in the drawing
views and add the other annotations such as notes, surface finish symbols, geometric tolerance,
and so on. There are two types of annotations that can be displayed in the drawing views. The
first type of annotation is the generative annotation. These annotations are added while
creating the part in the part mode. For example, the dimensions that you add to the sketch
and features of the part. The second type of annotations are added manually to the geometry
of drawing views such as reference dimensions, notes, surface finish symbols, and so on. Both
these types of annotations are discussed next.

Generating Annotations Using the Model Items Tool

The Model Items tool is used to generate the annotations that were added while
creating the model in the part mode. To invoke this tool, choose the Model Items
button from the Drawing toolbar or choose Insert > Model Items from the menu

bar. The Insert Model Items dialog box is displayed as shown in Figure 13-1. The various
options available in this dialog box are discussed next.

Annotations
The Annotations area of this dialog box is used to select the annotations that you need to
generate in the drawing views. Using the options available in the Annotation area you can
generate the cosmetic thread, datums, datum targets, dimensions, geometric tolerances, notes,
surface finish, and weld symbols. Select the annotation to be generated from this area.

Reference geometry
The Reference geometry area is used to generate the reference geometries that were used in
creating the model. You can generate axes, curves, planes, surfaces, and so on. Select the
check box of the reference geometry that you need to generate in the drawing views.

Import from
The options available in the Import from area are used to define the options from where
the annotation should be imported. The options available in this area are discussed next.

Entire model
The Entire model radio button is selected to import the annotations from the entire
model when a feature of a model is selected from the FeatureManager Design Tree
flyout in the Drawing mode. In case of assemblies, the annotations from the entire assembly
are imported even if you select a single component of the assembly.

Selected component
The Selected component radio button is active if you select a component of the assembly
from the FeatureManager Design Tree. This radio button is selected to import the
annotations from only the selected component.

Toolbar: Annotation > Model Items
Menu: Insert > Model Items
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Figure 13-1  The Insert Model Items dialog box

Selected feature
The Selected feature radio button is active if you select a feature of the component from
the FeatureManager Design Tree. This radio button is selected to import the
annotations from only the selected feature or features.

Only Assembly
The Only Assembly radio button is active when you generate the drawing views of an
assembly. This radio button is selected to import the annotations that are applied to the
assembly in the Assembly mode such as offset distance and so on.

All types
The All types check box is selected if you need to display all the annotations applied to the
part or assembly.

Include items from hidden features
The Include items from hidden features check box is selected to display the annotation that
belongs to a hidden feature of the model. By default, this check box is cleared. It is
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recommended that you clear this check box because it will eliminate the display of
unwanted annotations.

Import items into all views
The Import items into all views check box is selected to display the annotation in all the
views. The annotations are automatically distributed in all the drawing views. If you need to
display the annotations in a selected view or views only, clear this check box. When you clear
this check box, the Import to views display area is displayed below the Help button. You can
select the views in which you need to display the annotations. You can also preselect the views
in which you need to display the annotations before invoking the Insert Model Items dialog
box.

Eliminate duplicate model dimensions
The Eliminate duplicate model dimensions check box is selected to prevent the display of
the same annotation more than once.

After setting all the parameters in the Insert Model Items dialog box, choose the OK button
to display the annotations.

Creating the Reference Annotations
In SolidWorks, you can create the reference annotations in the drawing views. The reference
annotations include reference dimensions, notes, surface finish symbols, datum feature symbol,
geometric tolerance, and so on. The method of creating the reference annotations is discussed
next.

Tip. When you generate the annotations, mostly the annotations overlaps one over
the other. Therefore, you may need to move the annotations after generating. To
move an annotation, move the cursor on the annotation; a red rectangle is displayed.
Press and hold down the left mouse button and drag the cursor to place the annotation
at the desired location. Release the left mouse button when the cursor is placed at
the desired location.

The dimensions generated while generating the annotations are parametric
dimensions and these dimensions are the link of bidirectional associativity in
SolidWorks. To modify the dimensions, double-click the dimension; the Modify
dialog box is displayed. Using this dialog box you can modify the value of dimension.
After modifying the dimensions choose the Rebuild button from the Standard tool
bar or choose CTRL+B from the keyboard.

The modification implemented in the Drawing mode will also be reflected in the
Part mode and the Assembly mode.

If you need to delete a particular generated annotation, select the annotation from
the drawing sheet and press the DELETE key from the keyboard. The annotation
deleted from the drawing view will not be deleted from the part in the Part mode.
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Creating Reference Dimensions

In the Drawing mode of SolidWorks, you can use the Dimension tool to add reference
dimensions to the drawing views. This tool is similar to the Dimensions tool discussed
in the sketcher environment of SolidWorks. The additional dimensioning option

is provided in the Drawing mode of SolidWorks is discussed next.

Chamfer Dimension
The Chamfer Dimension option is used to add the reference dimension to the chamfers
available in the drawing view. To add a chamfer dimension choose Insert > Dimensions
> Chamfer Dimension from the menu bar. You can also invoke this tool by choosing the
Dimension button from the Sketch Relations toolbar and then choosing the Chamfer
Dimension option by invoking the shortcut menu. The cursor is replaced by the
chamfer dimension cursor. Now, select the inclined chamfered edge and then select a
horizontal or vertical edge. The chamfer dimension will be attached to the cursor. Select
a point on the sheet to place the dimension. Figure 13-2 shows a chamfer dimension
created using the Chamfer Dimension option.

Adding Notes to the Drawing Views

In SolidWorks, you can also add notes to the drawing views in the Drawing mode. To
add notes to the drawing view, choose the Note button from the Annotation toolbar

Toolbar: Sketch Relations > Dimension
Menu: Tools > Dimensions

Figure 13-2  Chamfer dimension created using the Chamfer
Dimension tool

Toolbar: Annotation > Note
Menu: Insert > Annotations > Note
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or choose Insert > Annotations > Note from the menu bar. The Note PropertyManager is
displayed as shown in Figure 13-3.

When you invoke the Note PropertyManager, a text box is attached to the cursor. When you
move the cursor close to an existing entity in the drawing sheet, a leader will be displayed
attached to the text box. This is because the Auto Leader button is chosen in the Arrows/
Leaders rollout. Place the text box at the desired location. As you place the text box, the text
edit box will be invoked and you can enter the text. After entering the text, choose OK from
the Note PropertyManager. The other options available in the Note PropertyManager are
discussed next.

Arrows/Leaders
The options available in the Arrows/Leaders rollout are used to define the style of arrows
and leaders that are displayed in the notes.

Text Format
The Text Format rollout is used to set the format of text such as font, size, justification,

Figure 13-3  The Note PropertyManager
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and rotation of the text. You can also add the symbols and hyperlink to the text using the
options available in this rollout.

Border
The options available in the Border rollout are used to define the border in which the
note text will be displayed. You can use various types of borders from the Style drop-down
list. The Size drop-down list available in this rollout is used to define the size of the
border in which the text will be placed.

Adding Surface Finish Symbols to the Drawing Views

You can add the surface finish symbols to the drawing views using the Surface Finish
tool. To add the surface finish symbols, choose the Surface Finish button from the
Annotation toolbar or choose Insert > Annotations > Surface Finish from the menu

bar. The Properties dialog box is displayed as shown in Figure 13-4.

Toolbar: Annotation > Surface Finish
Menu: Insert > Annotations > Surface Finish

Figure 13-4  The Properties dialog box

c13-solidworks-2003.p65 5/12/2003, 12:12 PM7



13-8 SolidWorks for Designers

As you invoke this tool, a surface finish symbol is attached to the cursor. The  options available
in the Properties dialog box are discussed next.

Preview Area
The preview area is used to preview the surface finish symbol with the current parameters.
As you modify the parameters of the surface finish symbol, the preview updates dynamically
in the preview area.

Symbol
The Symbol drop-down list is used to define the type of surface finish symbols that you
can add to the drawing views. The surface finish symbols include the Basic surface finish
symbol, Machining Required, Machining Prohibited, JIS Surface Texture 1, JIS Surface
Texture 2, JIS Surface Texture 3, JIS Surface Texture 4, and JIS No Machining.

Direction of lay
The Direction of lay drop-down list is used to define the direction of lay in the surface
finish symbol. This drop-down list is available when only the Basic, Machining Required,
or Machining Prohibited option is selected from the Symbol drop-down list.

Roughness
The Roughness area available in the Properties dialog box is used to define the surface
roughness values to be displayed in the surface finish symbol.

Rotated
The Rotated check box is selected to rotate the surface finish symbol at an angle of 90º.

Special requirements
The Special requirements area is used to enter the information such as production method/
treatment, sampling length, and some other roughness values, if there is any.

Material removal
The Material removal area is used to define the material removal allowance to be displayed
in the surface finish symbol.

Leader
The Leader area is used to define the style and properties of the leader and the arrow
that will be attached to the surface finish symbol.

Font
The Font area is used to define the font and the font size to be used in the text added in
the surface finish symbol.

c13-solidworks-2003.p65 5/12/2003, 12:12 PM8



Working With Drawing Views-II       13-9

Adding Datum Feature Symbol to the Drawing Views

The Datum Feature Symbol tool is used to add the datum feature symbol to the
drawing views. The datum feature symbols are used as datum references while adding
the geometric tolerances in the drawing view. To add the datum feature symbol, choose

the Datum Feature Symbol button from the Annotation toolbar or choose Insert >
Annotations > Datum Feature Symbol from the menu bar. The Properties dialog box is
displayed and a datum feature symbol with default parameters is attached to the cursor. The
Properties dialog box used to add the Datum Feature Symbol is displayed in Figure 13-5.

The options available in the Properties dialog box to add the datum feature symbol are
discussed next.

Preview Area
The preview area available in this dialog box is used to preview the datum feature symbol.
By default, the datum symbol feature is displayed in the preview area with the default
parameters. The preview of the datum feature symbol updates dynamically as you modify
the parameters of the datum feature symbol.

Datum display type
The Datum display type drop-down list is used to define the border that will be displayed
around the label of the datum feature symbol. The border of the datum feature symbol is
displayed as a square by default. You can also display the border of the datum feature
symbol as a circle using this drop-down list.

Toolbar: Annotation > Datum Feature Symbol
Menu: Insert > Annotations > Datum Feature Symbol

Figure 13-5  The Properties dialog box used to add
datum feature symbol to the drawing views
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Label
The Label edit box is used to define the label to be used in the datum feature symbol.

Display with filled triangle
The Display with filled triangle check box is selected to display a filled triangle at the
bottom of the datum feature symbol.

Display with shoulder
The Display with shoulder check box is selected to display the datum feature symbol
with a shoulder created at 90º.

After defining all the parameters of the datum feature symbol, specify a point on an
existing entity in the drawing sheet and then move the cursor to define the length and
the placement of the datum feature symbol. As you place one datum feature symbol,
another datum feature symbol is attached to the cursor. Therefore, you can place as many
datum feature symbols as you want using the Properties dialog box. The sequence of the
names of datum feature symbols automatically follows the alphabetical order as you place
multiple datum feature symbols.

Adding Geometric Tolerance to the Drawing Views

In a shop floor drawing, you need to provide various other parameters along with the
dimensions and dimensional tolerance. These parameters can be geometric condition,
surface profile, material condition, and so on. All these parameters are defined using

the geometric tolerance. To add the geometric tolerance to the drawing views, choose the
Geometric Tolerance button from the Annotation toolbar or choose Insert > Annotations >
Geometric Tolerance from the menu bar. The Properties dialog box will be displayed. It will
be used to define the parameters of the geometric tolerance. When you invoke this tool, a
geometric tolerance is attached to the cursor. The Properties dialog box is shown in Figure 13-6.

Various options available in the Properties dialog box to add the geometric tolerance to the
drawing views are discussed next.

Feature control frames
The Feature control frames area is used to define the features of geometric tolerance to
be added in the frames. The features of the geometric tolerance that can be added in the
frames are geometric condition symbols, diameter symbol, value of tolerance, material
condition, and datum references. The options available in the Feature control frames
area are discussed next.

GCS
The GCS button available in the Feature control frames area is used to
define the geometric condition symbol. When you choose this button, the
Symbols dialog box is displayed, which is used to define the geometric

condition symbols in the geometric tolerance. The Symbols dialog box is shown in

Toolbar: Annotation > Geometric Tolerance
Menu: Insert > Annotations > Geometric Tolerance
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Figure 13-6  The Properties dialog box used to apply geometric tolerance

Figure 13-7. You can specify the standard of the geometric condition symbol from the
Symbol library drop-down list. After selecting the appropriate geometric condition
symbol, choose the OK button from this dialog box. The preview of the geometric
tolerance is displayed in the preview area.

Tolerance 1
The Tolerance 1 edit box is used to specify the tolerance value with respect to the
geometric condition defined using the GCS button. Using the Diameter button, you
can add a diameter symbol with the tolerance value. Using the MC button available
next to the Tolerance 1 edit box, you can specify the material condition in the
geometric tolerance. When you choose the MC button, the Symbols dialog box is
displayed, see Figure 13-8. This dialog box is used to define the symbol for the material condition.

Figure 13-7  The Symbols dialog box used to define
the geometric condition symbols
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Tolerance 2
The options available in the Tolerance 2 edit box are the same as those discussed
earlier. This edit box is used to define the second geometric tolerance, if required.

Primary
The Primary edit box is used to specify the alphabets to define the datum reference
added to the drawing view using the Datum Feature Symbol tool. Similarly, you can
define the Secondary datum reference and the Tertiary datum reference.

Frames
The Frames spinner is used to increase the frames for applying more complex
geometric tolerances.

Projected tolerance zone
The Projected tolerance zone area is used to define the height of the projected tolerance.
Select the Show PTZ check box from the Projected tolerance zone area; the Projected
tolerance zone edit box will be displayed. Specify the zone height in this edit box.

Options
The Options button is used to define the settings of the leader, arrow, font, and so on.
When you choose this button, the Geometric Tolerance Options dialog box is displayed.
Using this dialog box you can set the parameters for leader style, arrow style, font, and so
on.

Between two points
The Between two points check box is selected if the geometric tolerance to be applied is
between two points of entities. To apply the geometric tolerance between two points or
entities select the Between two points check box and specify the tolerance in the edit
boxes provided in the Between two points area.

Figure 13-8  The Symbols dialog box used to define
the symbol for material condition
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Figure 13-9 shows a drawing after adding annotations to the drawing.

Adding Datum Target Symbols to the Drawing Views

The Datum Target tool is used to add a datum target to the drawing views. To add the
datum targets to the drawings, choose the Datum Target button from the Annotations
toolbar or choose Insert > Annotations > Datum Target from the menu bar. The

cursor is replaced by the datum target cursor. Select a model face, an edge, or a line from the
view on which you need to add the datum target. The Properties dialog box is displayed as
shown in Figure 13-10. This dialog box is used to define the properties of the datum target
symbol. Set the parameters of the datum target symbol in the Target area of this dialog box.
You can set the target shape as a point, circle, or rectangle; you can also define the diameter
of the target area if the shapes of the target are selected as point and circle using the Target
area. If the shape of the target is selected as rectangle then you need to define the length and
width of the rectangle. Using the Datum referrence(s) edit box you can specify the datum
references to the datum target symbol. Figure 13-11 shows the datum target symbols added to
drawing view.

Figure 13-9  A drawing after adding some annotations

Toolbar: Annotation > Datum Target (Customize to Add)
Menu: Insert > Annotations > Datum Target
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Figure 13-10  The Properties dialog box used to add the datum target
symbol to the drawing views

Figure 13-11  Datum target symbols added to the model
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Adding Center Marks to the Drawing Views

The Center Mark tool is used to add center marks to the circular entities. As discussed
earlier, center marks are automatically generated when you generate the model. But
if the center marks are not generated while generating the drawing view, or if you

have sketched a view, you can use this tool to add the center marks to the drawing views. To
add the center marks to the drawing views, choose the Center Mark button from the
Annotations toolbar or choose Insert > Annotation > Center Mark from the menu bar. The
Center Mark PropertyManager will be displayed as shown in Figure 13-12.

When you invoke the Center Mark PropertyManager, the cursor is replaced by the center
mark cursor and you are prompted to select a circular edge or an arc for the Center Mark
insertion. By default, the Single Center Mark button is selected in the Options rollout of the
Center Mark PropertyManager. Select the circular edge or arc to add the center mark.
Figure 13-13 shows the center marks added using the Single Center Mark button selected
from the Options rollout.

Toolbar: Annotation > Center Mark
Menu: Insert > Annotations > Center Mark

Figure 13-12  The Center Mark PropertyManager
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Figure 13-13  Center marks added using the
Single Center Mark option

Figure 13-14  Center marks added using the
Linear Center Mark option

If you add center marks to a hole that is part of a linear or circular pattern, the Propagate
button appears on the center mark. If you choose this button the center mark is added to all
the remaining instances of the pattern.

The center mark in rectangular and circular patterns can also be applied using the Linear
Center Mark and Circular Center Mark buttons. If you select the Linear Center Mark button
from the Options rollout, then you can add the center mark in the linear pattern format.
Since the Connection lines check box is selected by default, the center mark will be connected
using the center lines. Figure 13-14 shows the center marks added using the Linear Center
Mark button with the Connection lines check box selected.

Using the Circular Center Mark button, you can create the center mark in the circular pattern
format. When you select the Circular Center Mark button from the Options rollout, the
Circular lines check box, Radial lines check box, and the Base  center mark check box are
displayed. The Circular lines check box is used to create a circular line around the centers of
the circle arranged in the form of circular pattern. The Radial lines check box is used to
display the radial lines with the center mark. The Base center mark check box is used to
display the base center mark. Figure 13-15 shows the center mark created with the Base
center mark check box cleared. Figure 13-16 shows the center mark created with the Base
center mark check box selected. Figure 13-17 shows the center mark created with the Radial
lines check box selected.

The Display Attributes rollout available in the Center Mark PropertyManager is used to
define the size of the center mark and the extended lines. The Angle rollout is used to rotate
the center mark at an angle.
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Figure 13-15  Center marks created with the Base
center mark check box cleared

Figure 13-16  Center marks created with the
Base center mark check box selected

Figure 13-17  Center marks created with the Radial lines check box selected

Adding Center Lines to Views

The Centerline tool is used to create the centerlines in the views by selecting two
edges/sketch segments or a single cylindrical/conical face. To create a centerline, choose
the Centerline button from the Annotation toolbar or choose Insert > Annotations

> Centerline from the menu bar. The Centerline PropertyManager is invoked and it prompts
you to select two edges/sketch segments or a single cylindrical/conical face. Select the entity
or entities from the view to add the centerline. Figure 13-18 shows the center lines added to
the drawing views by selecting the surface.

Toolbar: Annotation > Centerline
Menu: Insert > Annotations > Centerline
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Figure 13-18  Centerlines added using the Center Mark tool

Adding Hole Callout to the Views

The Hole Callout tool is used to generate the hole callouts that are created in Part
mode using the Hole PropertyManager, Hole Wizard, or cut option. To generate a
hole callout, choose the Hole Callout button from the Annotation toolbar or choose

Insert > Annotations > Hole Callout from the menu bar. The cursor will be replaced by the
hole callout cursor. Select the hole from the drawing views; the hole callout will be attached to
the cursor. Pick a point on the drawing sheet to place the hole callout. Figure 13-19 shows a
drawing view with hole callouts generated using the Hole Callout tool.

Adding the Cosmetic Threads to the Drawing Views

The Cosmetic Thread tool is used to add cosmetic threads that will display the thread
conventions in the drawing views. To add a cosmetic thread in the drawing view,
select the circular edge from the drawing view on which you need to apply the cosmetic

thread. Now, choose the Cosmetic Thread button from the Annotation toolbar or choose

Toolbar: Annotation > Hole Callout
Menu: Insert > Annotations > Hole Callout

Toolbar: Annotation > Cosmetic Thread (Customize to Add)
Menu: Insert > Annotations > Cosmetic Threads

Tip. You can also set the option for the automatic creation of centerline while
generating the drawing views. Choose Tools > Options from the menu bar to
invoke the System Options- General dialog box. Select the Document Properties
tab from this dialog box. Select the Centerlines check box from the Auto insertion
on view creation area and choose OK to close the dialog box.

You can also directly select a view to add the centerlines.
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Figure 13-19  Hole callouts generated using the Hole Callout tool

Insert > Annotations > Cosmetic Thread from the menu bar. The Cosmetic Thread
PropertyManager is displayed as shown in Figure 13-20.

The options available in the Cosmetic Thread dialog box are discussed next.

Figure 13-20  The Cosmetic Thread dialog box
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Preview Area
The preview area is used to display the preview of the cosmetic thread. The preview of the
cosmetic thread modifies dynamically as you modify the parameters of the cosmetic thread.

Selection Area
The selection area is used to display the name of the selected entity on which you need to
apply the cosmetic thread.

Apply thread
The Apply thread area is used to define the depth of the cosmetic thread.

Major diameter
The Major diameter spinner is used to define the major diameter of the thread.

Thread callout
The Thread callout edit box is used to specify the text to be used in the thread callout
for the cosmetic thread.

After setting all the parameters, choose the OK button from the Cosmetic Thread dialog
box. When you add a cosmetic thread to a generated drawing view, the thread convention will
be displayed in all the drawing views. Figure 13-21 shows the cosmetic thread added to the
model.

Figure 13-21  Cosmetic threads added to the drawing views

Tip. You can change the model display setting from hidden lines removed to hidden
lines visible, or wireframe, shaded using the options available in the View toolbar.
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Note
The thread conventions once added in the drawing view can only be deleted from the part file.
You cannot delete the thread convention from the drawing file. To delete the thread convention
in the part file, expand the Hole or Cut feature in the FeatureManager Design Tree. Now,
select the thread convention and delete it.

Adding Weld Symbols to the Drawing Views

The Weld Symbol tool is used to add the welding symbol to the drawing views. To
add the welding symbol, select the edge or the vertex where you need to add the weld
symbol and choose the Weld Symbol button from the Annotation toolbar or choose

Insert > Annotations > Weld Symbol from the menu bar. The Properties dialog box will be
displayed as shown in Figure 13-22.

The options available in the dialog box are discussed next.

Dimension
The Dimension area is used to specify the dimension of the weld and the welding symbol.
The Weld Symbol button available in the this area is used to define the welding symbols

Toolbar: Annotation > Weld Symbol (Customize to Add)
Menu: Insert > Annotations > Weld Symbol

Figure 13-22  The Properties dialog box used to add the welding symbols to the drawing views
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from the Symbols dialog box displayed in Figure 13-23. Using the edit boxes available in
this area you can define the dimension of weld.

Top/Bottom
Using the Top radio button and the Bottom radio button you can specify if you need to
display the welding symbols on the top or at the bottom.

Contour
The Contour drop-down list is used to define the shape of the cross-section of the weld
contour to be flat, convex, or concave.

The other options available in this dialog box are used to define if you need a symmetric
weld, peripheral weld, field, site weld, identification line, and indication of welding process.

Stagger
The Stagger check box is selected to define the stagger in the weld symbol.

After specifying all the parameters in the Properties dialog box, choose the OK button to
exit the dialog box and place the weld symbol. Figure 13-24 shows the weld symbol added to
the drawing view.

Adding the Multi-jog Leader to the Drawing Views

Using the Multi-jog Line tool you can add a multi-jog leader line to the drawing
views. A multi-jog leader is basically a leader in which you can add multiple jog lines.
To add a multi-jog leader, choose the Multi-jog Leader button from the Annotation

toolbar or choose Insert > Annotations > Multi-jog Leader from the menu bar. The cursor
will be replaced by the multi-jog line cursor. Select a point on the sheet or on an entity from
where you need to start the leader. Now, specify the points on the drawing sheet to specify the

Figure 13-23  The Symbols dialog box used to define the weld symbols

Toolbar: Annotation > Multi-jog Leader (Customize to Add)
Menu: Insert > Annotations > Multi-jog Leader
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Figure 13-24  Welding symbol added to the model

jogs and then select the second entity where the second end of leader will be placed. A multi-jog
leader will be created. Double-click the sheet to end the multi-jog leader creation. Figure 13-25
shows a multi-jog leader added to the drawing view.

Adding the Dowel Pin Symbols to the Drawing Views

The Dowel Pin Symbol tool is used to add the dowel pin symbol to the holes in the
drawing views. The dowel pin symbol is used to confirm the size of the selected hole.

Figure 13-25  Multi-jog leader added to the drawing view

Toolbar: Annotation > Dowel Pin Symbol (Customize to Add)
Menu: Insert > Annotations > Dowel Pin Symbol
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To create a dowel pin symbol, select a hole or circular edge from the drawing view and choose
the Dowel Pin Symbol button from the Annotation toolbar or choose Insert > Annotations
> Dowel Pin Symbol from the menu bar. The Dowel Pin Symbol PropertyManager is
displayed. Using the Flip symbol check box in the Display Attributes rollout, you can flip
the direction of the dowel pin symbol.

EDITING THE ANNOTATIONS
You can edit the annotation added to drawing view by selecting them or by double-clicking
them to display their respective PropertyManager or dialog box. Using the PropertyManager
or dialog box you can edit the parameters of the annotations.

ADDING THE BOM AND BALLOONS IN THE DRAWING

The BOM, also known as Bill of Materials, is a table that provides you the information related
to the number of components in an assembly, their name, their quantity, and other related
information. You can add the BOM in the drawing sheet to display the part list of the
components used in the assembly. The BOM placed in the drawing document is parametric
in nature. Therefore, if you add or delete a part from the assembly, the change will be reflected
in the BOM in the assembly document. To insert a BOM in the drawing file having the
drawing views of an assembly, select any one view from the drawing document and choose
Insert > Bill of Materials from the menu bar. The Select BOM Template dialog box is
invoked. Using this dialog box you can select the default BOM templates provided in
SolidWorks. Select the bomtemp.xls file from the Select BOM Template dialog box and
choose the Open button. The Bill of Materials Properties dialog box will be displayed as
shown in Figure 13-26.

Menu: Insert > Bill of Materials

Figure 13-26  The Bill of Materials Properties dialog box
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Figure 13-27  The Contents tab of the Bill of Materials Properties
dialog box

The options available in this dialog box are discussed next.

Configuration Tab
The options available in the Configuration tab are used to specify the information to be
included in the BOM and the parts and the subassemblies to be included in the BOM. The
options available in this dialog box are discussed next.

The Anchor point area available in this dialog box is used to define the point of placement of
the BOM. The Use table anchor point check box is used to coincide the anchor point of the
drawing sheet with the anchor point of the BOM. You will learn more about anchor point
later in this chapter. The Anchor point coincident to drop-down list is used to define the
point of the BOM that should coincide with the drawing sheet anchor point.

Contents
The Contents tab is used to display the content of the parts to be used in the BOM. When you
select the Contents tab from this dialog box, the preview of the BOM attached to the top left
corner of the drawing sheet is displayed. The Contents tab selected from the Bill of
Materials Properties dialog box is displayed in Figure 13-27.

The parts that will be displayed in the BOM are checked with a green check mark in the
Contents tab of the Bill of Materials Properties dialog box. You can clear the check mark
from the parts that need not be included in the BOM.
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Figure 13-28  BOM added to the drawing sheet

Control
The Control tab is used to define the style from the row numbers. You can also split the table
using the options available in this tab.

After setting all the parameters, choose OK from this dialog box. The BOM will be placed at
the top-right corner of the drawing sheet. Figure 13-28 shows the BOM added to the drawing
sheet.

Tip. You can edit the BOM placed in the drawing sheet by just double-clicking the
BOM; the Microsoft Excel environment will be invoked and using the tools available
in Microsoft Excel, you can edit or modify the BOM. Double-click the drawing
sheet to return to the assembly environment.

You can set the anchor of the drawing sheet by expanding Sheet Formats 1 from
the FeatureManager Design Tree. Select the Bill of Materials Anchor and
right-click to invoke the shortcut menu. Choose the Set Anchor option from the
shortcut menu. The current anchor will be displayed as a point on the drawing
sheet. Select a point in the drawing sheet where you need to specify the anchor point
for placing the BOM. Now, select Sheet 1 from the FeatureManager Design
Tree and choose the Edit Sheet option by invoking the shortcut menu to return to
the edit sheet environment.

You can also unlock the BOM from the anchor point so that it can be moved freely
anywhere. To unlock the BOM, right-click it and choose Anchor > Unlock from
the shortcut menu. The shortcut menu also has some other options such as Hiding
or Editing the BOM.
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Figure 13-29  The Balloon PropertyManager

Adding Balloons to the Drawing Views

The Balloon tool is used to add the balloons to the components of the assembly in
the drawing view. The naming of balloons depends on the sequence of the parts in
BOM. To add balloons to the drawing view, choose the Balloon button from the

Annotation toolbar or choose Insert > Annotations > Balloon from the menu bar. The
Balloon PropertyManager is displayed as shown in Figure 13-29.

After invoking the Balloon PropertyManager, you are prompted to select one or more locations
to place balloons. Select the components from the assembly drawing view to add the balloons.
If you select the face of a component, the balloon will have a filled circle at the attachment
point. However, if you select an edge of the component, the balloon will have a closed fillet
arrow. After placing all the balloons, choose the OK button from the Balloon PropertyManager.
You may have to select and move the balloons after placing them. Figure 13-30 shows the
drawing sheet in which balloons are added.

ADDING NEW SHEETS TO THE DRAWING VIEWS
You can also add new sheets to the drawing document. A multi-sheet drawing document is
generally used when you need to generate the drawing views of all the components and the
drawing views of the assembly in the same document. You can switch between the sheets easily
to refer to the drawings of different parts of an assembly within the same document and you
do not need to open the separate drawing documents. To add a sheet to the drawing document,
select Sheet 1 from the FeatureManager Design Tree and invoke the shortcut menu. Choose
the Add Sheet option from the shortcut menu to add a sheet to the drawing document or
choose Insert > Sheet from the menu bar. The Sheet Setup dialog box is displayed. Using

Toolbar: Annotation > Balloon
Menu: Insert > Annotations > Balloon
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this dialog box you can specify the name, standard sheet format, and scale projection type for
the drawing sheet to be added. Choose the OK button from this dialog box; a new sheet will
be added in the drawing document. Figure 13-31 shows a drawing document with four drawing
sheets added and Sheet 4 as the active sheet.

Figure 13-31  Drawing sheets added to the drawing document

Figure 13-30  Balloons added to the assembly drawing view
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To activate a drawing sheet, select the sheet from the FeatureManager Design Tree and
invoke the shortcut menu. Choose the Active option from the shortcut menu to activate the
selected sheet. You can also activate the sheet by selecting the sheet tab from the bottom of
the drawing document.

EDITING THE SHEET FORMAT
You can edit the default standard sheet format according to your requirement. To edit the
standard sheet format, select Sheet 1 from the FeatureManager Design Tree and invoke the
shortcut menu. Choose the Edit Sheet Format option from the shortcut menu. All the entities,
annotations, and views will disappear from the drawing sheet. Using the sketching tools
available in the Sketch Tools toolbar you can edit the sheet format. After editing the sheet
format select Sheet 1 and invoke the shortcut menu. Select the Edit Sheet option from the
shortcut menu to switch back to the edit sheet environment.

CREATING A USER-DEFINED SHEET FORMAT
In SolidWorks you can also create a user-defined sheet format. To create a user-defined sheet
format, create a new drawing document with standard size with the No Sheet Format option
from the Sheet Format To Use dialog box. Select Sheet 1 from the FeatureManager Design
Tree and invoke the shortcut menu. Choose the Edit Sheet Format option from the shortcut
menu. The edit sheet format environment is invoked. Using the standard sketching tools
available in the Sketch Tools toolbar you can create the sheet format. After creating the sheet
format switch back to the edit sheet environment. Choose File > Save Sheet Format from the
menu bar. The Save Sheet Format dialog box is displayed. Select the Custom sheet format
radio button from this dialog box and browse the location where you need to save the sheet
format. Specify the name of the sheet format and choose the save button from the Save As
dialog box. The location and name of the sheet format will be displayed in the Custom sheet
format edit box. Choose the OK button from the Save Sheet Format dialog box. Next time
when you invoke the Sheet Format To Use dialog box, you can retrieve the saved sheet format
by selecting the Custom sheet format radio button and browse the location using the Browse
button. Figure 13-32 shows a user-defined sheet format.
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TUTORIALS

Tutorial 1
In this tutorial you will open the drawing created in Tutorial 2 of Chapter 7 and generate the
dimensions and add the annotations to the drawing. After that you will change the display of
the front and the right view to hidden lines visible, and the display of the isometric and
aligned section view to shaded mode.     (Expected time: 45 min)

The steps to be followed to complete this tutorial are discussed next:

a. Copy the model and the drawing document in the current directory.
b. Configure the font settings and generate the dimensions using the Insert Model Items tool.
c. Generate and arrange the dimensions and delete the unwanted dimensions, refer to

Figures 13-34 and 13-35.
d. Add the datum symbol and geometric tolerance to the drawing views, refer Figures 13-36

and 13-37.
e. Change the model display state of the drawing views, refer to Figure 13-38.

Copying the Model in the Current Directory
First, you need to copy the model and the drawing document in the current directory.

1. Create a directory with the name c13 in the SolidWorks directory and copy c07tut02.sldprt
from the /My Document/SolidWorks/c7 directory to this directory.

Opening the Drawing Document
After copying the part and the assembly document, you need to open the drawing
document in the SolidWorks window.

Figure 13-32  A user-defined sheet format
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Figure 13-33  Drawing document in which you need to add the detailing

1. Invoke the Open dialog box and open c12tut01.sldprt document.

The drawing document in which you need to add the detailing is displayed in Figure 13-33.

Applying the Documents Settings
Before you start generating dimensions, you need to configure the document settings.

1. Invoke the Document Properties - Grid/Snap dialog box and select the Annotations
Font option from this dialog box.

2. The Note/Balloon option is selected in the Annotation type area. Select this option again.
The Choose Font dialog box will be invoked.

3. Select the Points radio button from the Height area and set the value of the font size to 9
from the list box.

4. Choose the OK button from the Choose Font dialog box. Similarly, set the font size for
dimension, detail, and section to 9.

5. Now, select the Arrow option from the Document Properties dialog box. The options
related to size and shape of the arrows are displayed.

6. Set the value of the Height as 1, Width as 3, and Length as 3 in the Size area.

7. In the Section/View size area, set the value of the Height as 3, Width as 6, and Length as
12.

8. Choose the OK button from the Document Properties - Grid/Snap dialog box.
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After applying the document setting, you need to generate the dimensions of the drawing
view.

Generating the Dimensions
Next, you need to generate the dimensions using the Insert Model Items tool. As discussed
earlier, if you do not select any view and generate the dimensions using the Insert Model
Items tool, all the dimensions will be displayed in all the views. Therefore, sometimes the
dimensions overlap each other and it becomes confusing to judge which dimension is of
which view. Therefore, you will select the view in which you need to generate the dimension
and then you will invoke the Insert Model Items tool.

1. Select the top view and choose the Model Items button from the Annotation
toolbar. The Insert Model Items dialog box is displayed. The name of the selected
view is displayed in the Import to views display area.

2. Choose the OK button from the Insert Model Items dialog box.

The dimensions of the model that can be displayed in the selected view are generated. If
a radial dimension is attached to the counterbore hole in the top view, it needs to be
deleted because you will add a hole callout to this counterbore hole.

3. Select the radial dimension and press the DELETE key from keyboard to delete the
dimension.  Similarly, delete the dimension of diameter 20.

The dimension arrows are displayed as no filled, but need to be filled dimension arrows.

4. Drag a window such that all the dimensions are enclosed inside the window. Release the
left mouse button to select all the generated dimensions.

The Dimension PropertyManager is displayed.

5. Select the Filled Arrow option from the Style drop-down list of the Arrow rollout.

The arrows will be changed to filled arrows. The dimensions are scattered arbitrarily on
the drawing sheet. Therefore, you need to arrange the dimensions by moving them to
the required locations.

6. Select the dimension one by one and drag them to the desired location, refer to
Figure 13-34.

7. Now, select the aligned section view and generate the dimensions using the Insert Model
Items tool and move the dimensions to place them at appropriate places, refer to
Figure 13-35.

8. Choose the Hole Callout button from the Annotation toolbar and select the outer
circle of one of the counter bore feature. The hole callout will be attached to the
cursor. Pick a point on the drawing sheet to place the hole callout.
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Adding the Datum Feature Symbol to the Drawing View
After generating the dimensions, you need to add the datum feature symbol to the drawing
view. Datum feature symbols are used as the datum reference for adding the geometric
tolerance to the drawing views.

1. Select the edge of the outer cylindrical feature from the top view and then choose
the Datum Feature Symbol button from the Annotation toolbar.

Figure 13-34  The dimensions generated using the Insert Model
Items tool

Figure 13-35  The dimensions generated by selecting the aligned
section view
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The Properties dialog box will be displayed, which is used to define the parameters of
the datum feature symbol.

2. Choose the OK button from the Properties toolbar.

The datum feature symbol is placed at some default location.

3. Select the datum feature symbol and drag and place it at a location as shown in Figure 13-36.

Adding the Geometric Tolerance to the Drawing View
After defining the datum feature symbol, you will add the geometric tolerance to the
drawing view.

1. Select the circular edge that has a diameter of 12 from the top view and choose
the Geometric Tolerance button from the Annotation toolbar.

The Properties dialog box is displayed. It is used to specify the parameters of the geometric
tolerance.

2. Choose the GCS button from the Feature control frames area. The Symbols
dialog box is displayed.

3. Choose the Concentricity and coaxiality option from the ISO Geometric Tolerancing
list box and choose the OK button from the Symbols dialog box.

4. Set the value of tolerance in the Tolerance 1 edit box to .002.

5. Specify A in the Primary edit box to define the primary datum reference.

Figure 13-36  Datum feature symbol added to the drawing view
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6. Choose the OK button from the Property dialog box. The geometric tolerance will be
placed attached to the selected circular edge.

You may need to move the geometric tolerance if it overlaps the drawing view. Figure 13-37
shows the drawing view after adding the geometric tolerance.

Changing the Display View Options
After adding all the annotations to the drawing views, you need to change the model
display setting as discussed in the description of this tutorial.

1. Press and hold down the CTRL key and select the front view and the right-side view from
the drawing sheet.

2. Choose the Hidden Lines Visible button from the View toolbar.

The hidden lines will be displayed in the selected drawing views.

3. Now, select the isometric view and the aligned section view from the drawing sheet.

4. Choose the Shaded button and the Display HRL Edges In Shaded Mode button from
the View toolbar.

Figure 13-38 shows the final drawing sheet after changing the display view settings.

5. Save the drawing file.

Figure 13-37  Geometric tolerance added to the drawing view
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Tutorial 2
In this tutorial you will generate the BOM of the Bench Vice assembly and then add balloons
to the isometric view in the exploded state.    (Expected time: 45 min.)

The steps to be followed to complete this tutorial are discussed next:.

a. Copy the Bench Vice folder that contains parts, assembly, and the drawing document in
the current directory.

b. Delete the views that are not required in the drawing sheet, refer to Figure 13-40.
c. Move to arrange the views in the drawing sheet, refer to Figure 13-40.
d. Set the anchor on the drawing sheet where the BOM will be attached.
e. Generate the BOM, refer to Figure 13-41.
f. Apply the balloons to the drawing view, refer to Figure 13-42.

Copying the Folder in the Current Directory
First, you need to copy the Bench Vice folder in the current directory.

1. Copy the Bench Vice folder from the /My Document/SolidWorks/c12 directory to the current
directory.

Figure 13-38  Final drawing sheet
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Opening the Drawing Document
After copying the part and the assembly document, you need to open the drawing
document in the SolidWorks window.

1. Open c12tut02.slddrw document.

The drawing document in which you need to generate the BOM and balloons is displayed
in Figure 13-39.

Deleting the Unwanted View
You need to delete the right-side view, as this view is not required in this tutorial.

1. Select the right-side view and press the DELETE key from the keyboard.

The Confirm Delete dialog box will be displayed.

2. Choose the Yes button from this dialog box. The view will be deleted from the current
drawing sheet.

Moving the Drawing View
You need to move the exploded isometric view because the BOM will be generated at the
top right corner of the drawing sheet.

1. Select the isometric view; the border of the view is displayed in green.

2. Move the cursor to the border. The cursor will be replaced by the move cursor.

Figure 13-39  Drawing document in which you need to generate BOM and balloons
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3. Drag the cursor to move the drawing view and place the view at the desired location, refer
to Figure 13-40.

Setting the Anchor for the BOM
Before generating the BOM, you need to set the anchor of the BOM. The anchor is a
point on the drawing sheet with which one corner of the BOM coincides. By default, the
anchor is defined at the top left corner of the drawing sheet. But in this tutorial you need
to add the BOM on the top right corner of the drawing sheet. Therefore, you will set
anchor before generating the BOM.

1. Expand Sheet 1 from the FeatureManager Design Tree and then expand Sheet Formats 1
to display the Bill of Materials Anchor 1 option.

2. Select the Bill of Materials Anchor 1 option and invoke the shortcut menu. Choose the
Set Anchor option from the shortcut menu.

As you move the cursor on the Bill of Materials Anchor 1 option, the anchor is displayed
as a point in the upper right corner of the drawing sheet.

3. Specify the anchor point on the inner top right corner of the drawing sheet. A point will
be placed at the selected location.

After setting the anchor, you need to switch back to the edit sheet environment.

4. Select Sheet 1 from the FeatureManager Design Tree and invoke the shortcut menu.
Choose the Edit Sheet option from the shortcut menu.

Figure 13-40  Drawing sheet after moving the drawing view
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Generating the BOM
Next, you need to generate the BOM. As discussed earlier, the BOM generated in
SolidWorks is parametric in nature. If a component is deleted or added in the assembly,
the change is automatically reflected in the BOM.

1. Select the isometric view and choose Insert > Bill of Materials from the menu bar.

The Select BOM Template dialog box will be displayed.

2. Select the bomtemp.xls file and choose the Open button from the Select BOM Template
dialog box.

The Bill of Materials Properties dialog box will be displayed.

3. Select the Top Right option from the Anchor point coincident to drop-down list.

4. Choose the OK button from the Bill of Materials Properties dialog box. The BOM is
generated. You will notice that the Description column does not have any data. You can
add more description by double-clicking the BOM.

The drawing sheet after generating the BOM is displayed in Figure 13-41.

Adding the Balloons to the Drawing View
After generating the BOM you need to add the balloons to the drawing views.

1. Choose the Balloon button from the Annotation toolbar.

The Balloon PropertyManager will be displayed. The cursor is replaced by the balloon
cursor.

Figure 13-41  Drawing sheet after generating the BOM
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2. Select the Vice Body from the isometric view displayed in shaded mode. A balloon will be
attached to the Vice Body with the sequence of the balloon as the item number displayed
in the BOM.

3. Select the Vice Jaw; the balloon will be attached to the Vice Jaw.

4. Similarly, add balloons to all the components in the assembly. You may need to move the
balloons, refer to Figure 13-42.

5. Now, drag a window and select all the balloons. Select the Tight Fit option from the Size
drop-down list in the Balloon PropertyManager. The final drawing sheet after adding
balloons to the drawing view is shown in Figure 13-42.

6. Save the drawing.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. You cannot add annotations while creating the part in SolidWorks. (T/F)

Figure 13-42  Final drawing sheet after adding balloons
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2. You can add the surface finish symbols to the drawing views. (T/F)

3. The Projected tolerance zone area is used to define the quality of the projected tolerance.
(T/F)

4. You can set the target shape as a point, circle, or rectangle while adding a datum target.
(T/F)

5. You can also set the option for the automatic creation of centerline while generating the
drawing views. (T/F)

6. The __________ spinner is used to define the major diameter of the thread.

7. The __________ tool is used to add the balloons to the components of the assembly in the
drawing view.

8. The __________ drop-down list available in the Properties dialog box to define the weld
symbol is used to define the shape of the cross-section of the weld contour to be flat,
convex, or concave.

9. The __________ tab of the Bill of Materials Properties dialog box is used to display the
content of the parts to be used in the BOM.

10. The __________ dialog box is invoked to select the default BOM templates provided in
SolidWorks.

REVIEW QUESTIONS
Answer the following questions:

1. The __________ tool is used to add the cosmetic threads that are used to display the
thread conventions in the drawing views.

2. The __________ tab available in this dialog box is used to define the row numbers and
you can also split the table using the options available in this tab.

3. You can change the model display setting from hidden lines removed to hidden lines
visible, or wireframe, or shaded using the options available in the __________ toolbar.

4. Select the __________ check box from the Auto insertion on view creation area to
automatically create centerlines while generating the view.

5. The __________ tool is used to create the centerlines in the views.
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6. Which dialog box is invoked when you choose the Weld Symbol  button from the
Annotation toolbar?

(a) Weld Properties (b) Weld Symbol
(c) Properties (d) Weld Joints

7. Which dialog box is displayed when you choose the Cosmetic Thread button from the
Annotation toolbar?

(a) Cosmetic Thread Properties (b) Cosmetic Thread
(c) Cosmetic Thread Convention (d) None of these

8. Which PropertyManager is used to add center marks to the drawing views?

(a) Add Center Mark (b) Create Center Mark
(c) Center Mark (c) Cosmetic Thread

9. Which area available in the Cosmetic Thread dialog box is used to define the depth of
the cosmetic thread?

(a) Apply Thread (b) Thread Depth
(c) Cosmetic Thread (d) None of these

10. Which PropertyManager is used to add balloons in the drawing views?

(a) Add Balloons (b) Balloon Properties
(c) Balloons (d) None of these

EXERCISE

Exercise 1
In this exercise you will generate the isometric view in exploded view of the assembly created
in Tutorial 1 of Chapter 11 on the standard A4 sheet format. The scale of the view will be 1:5.
After generating the view generate the BOM and add balloons to the assembly view shown in
Figure 13-43.    (Expected time: 30 min)

c13-solidworks-2003.p65 5/12/2003, 12:13 PM42



Working With Drawing Views-II       13-43

Figure 13-43  Drawing view for Exercise 1
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Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. T, 5. T, 6. Major Diameter, 7. Balloon, 8. Contour, 9. Contents, 10. Select
BOM Template
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